Servers and launcher not working.


New member
Feb 20, 2021
i tried to join RLCraft modrealms and it says it has no mods (i think.) the error is just a bunch of text that seems to say it needs a certain mod. i tried to download the launcher and it says "Fatal Error: Unable to Load Distribution Index." i tried downloading the same version and it has the same error!


Staff member
Apr 28, 2019
United Kingdom
Hey @Aartyyy

I've responded to your previous thread regarding your launcher problems here:

However, when this occurs - there are a few issues:
  • When your launcher is "Unable to Load Distribution Index", this is caused by your launcher being unable to download the launcher modpack listing file, which as of currently is around 6MB. This could take some time depending on your connection speed, but if the download fails due to your connection (or is unable to complete) this error will show and you will not have the most up to date modpack files on your launcher. This does not download modpack files, it only downloads the central-file that determines which files are needed to use the modpacks and where they're supposed to go. To resolve this issue, you will want to ensure your computer is connected to the internet and that your internet connection is strong enough (Generally, at least 1Mbps (0.12MB/s) internet speed should be enough)

  • When your modpack does not have any mods installed, this is most commonly due to not having selected your modpack inside of the selection menu, which you can access by clicking the 'Minecraft Forge' name in the bottom right of your launcher. Once you click this, you will see the wide variety of packs that we host on ModRealms, and can choose which one you would like to play (such as RLCraft). Upon launching your pack, your launcher will start downloading files which can also take some time depending on the speed. Please ensure that your launcher is connected to the internet during this time.
I hope this helps you out, please do let us know how you get on.